Having Issues with KODI 17.1 or 16.1 Here is KODI 17.0

KODI 17.0

KODI 17.0

Many people are having issues with the older and newer forms of Kodi. In my opinion everyone should now be using KODI 17.0 therefore bin KODI 16.1 and don't yet upgrade to 17.1 although this may change soon.

Below is the link to older versions of KODI and you can choose which one is right for your device.